Mozilla has released an update for Firefox addressing many CVEs security flaws, most of them considered to be high risk.

To download the patch you need to update your Firefox to the latest edition. In its latest update “Firefox 77” it has addressed 8 of the security flaws, in which 5 were high risk flaws, out of these 5, 3 flaws are confirmed to allow arbitrary code execution, i.e browser could have loaded malicious pages leading to malware running on your system.

If you have not updated your Firefox yet, it is recommended to do so.

if you want to know more in detail about the flaws read our CVE page: 

Firefox CVE’s vulnerability list.

 

Whats up with Whatsapp? why should you really worry? its alternatives?find out here.
The social media platform you use is a decently curated box for …
2 million+ CCP members secretly work in US, UK, Australia and India.
What's the fuss about? In the recent report by "The Australian" a data …

Have some thoughts? why not share with us here.

Hey we spotted an adblocker on your browser

Hello, Welcome to Stormbreaker.
We are happy that you opened our website but please disable the adblocker to view further.
Ads are a way this page is generating revenue and making this awesome site and people behind it working. 
Thank you in advanced.
Team Stormbreaker.